Character Vault
Any Concept / Any System
Compendium
Your System Come To Life
Roll20 for Android
Streamlined for your Tablet
Roll20 for iPad
Streamlined for your Tablet

Personal tools

Mapping with Gimp

From Roll20 Wiki

Jump to: navigation, search

Creating a Map using Gimp

This tutorial will focus on creating interior style maps and especially the classic dungeon. However, the techniques can be used to create any interior-style map.

  1. Create new canvas with the appropriate dimensions. Create new canvas by going to File->New…
    Create New Image.png
  2. Roll20 uses a grid size of 70px. The canvas should be a multiple of your grid size (i.e. a 700px by 700px grid will give you a grid of 10x10 squares. I’m using a 70px grid that will give me 20 squares by 20 squares
  3. Make sure the Grid is visible: View->Show Grid Chances are the Grid is not set to the dimensions you want, so to correct that, go to Image->Configure Grid…
    Configure Image Grid.png
  4. Make sure that Snap to Grid is enabled: View->Snap to Grid
  5. We want to lay the cover for the floor, so we will add a new layer called “Floor.” To do this, In the Layers dock, click the new Layer button and in the New Layer dialog box, make sure it has the same dimensions as your canvas (it should, by default), and give it the name of Floor.
    Create New Layer.png
  6. Select the Floor layer in the Layers dock.
  7. Make sure that the patterns dialog open. It should be part of the Layers dock, at the bottom. If it’s not, open by: Windows->Dockable Dialogs->Patterns, or Shift+Ctrl+P
  8. Select->All to select the entire layer.
  9. On the Patterns dock, find a floor cover you want to use for you floor and select it.
  10. On the Toolbox window, select the Fill bucket. It will look like this:
    Img04.png
  11. When you select it, you should get a Bucket Fill dialog as part of the bottom section of the toolbox. Make sure Pattern Fill is selected. The dialog should also show you what pattern you have selected.
    Bucket Fill Options.png
  12. Click inside the Floor layer and the pattern should fill the entire layer.
  13. Create a New Layer as before, but name this one Floor-color
  14. Click on the foreground color and change it to something obnoxious. This will enable beveling more easily.
    Foreground Color.png
  15. Click the Fill bucket in the Toolbox and make sure that FG color fill is selected
  16. Click the Floor-color layer and then click inside that layer’s image to fill with the color
  17. Create a new layer called Grid; in the Layer Fill Type, make sure that Transparency is selected
    Create Transparency Layer.png
  18. With the Grid layer selected, click Filter->Render->Pattern->Grid…
  19. Set the width values to the line thickness you desire
  20. Set the Spacing to the size of your grid. For example, if your grid needs to be 70x70px, then set those values to 70, intersection can be left as 0
  21. Set the Offset value to 0.
  22. Make sure your color boxes at the bottom are the color that you want for your grid lines. I use black.
    Render Grid Config.png
  23. Click Select->By Color
  24. Click the obnoxious color
  25. Your image should have a lot of dotted lines following the grid pattern.
  26. Click Select->Invert. This will make the grid lines as the select area.
  27. Click the eye next to the Floor-color layer. This will make the obnoxious color disappear, making things a little easier to work with.
  28. Select the Floor layer; the selection remains, but is now on the Floor layer.
  29. Click Filter->Decor->Add Bevel…
  30. You leave work on Copy select if you wish, but I unselect it, and click ok
  31. Your floor now has a beveled grid look to it.
  32. Add a new layer called Walls, make sure it’s the top layer.
  33. Hide (click the eye) all the layers except for Wall, Grid and Background (background should be white by default). This allows you to see what you are doing more easily as you create the walls of your map.
  34. On your toolbox, select the Paintbrush tool:
    Img09.png
  35. Select a brush. I like Circle (11)
    GIMP Toolbox.png
  36. The Foreground color isn’t as important, as we’ll be removing by filling it with a pattern once we are done. To make things easy, I just leave it as the same color that we used for the “Floor-color” layer.
  37. With “Snap to Grid” enabled, you can now click once on a grid intersection point and a circle of color should appear. You can then use Shift+click to extend straight lines from the last click point. Be sure to take the “outside wall” all the way to the edge. This will be important when we go to fill in the space later.
  38. Once your walls are laid out, you should have something that looks similar to this:
    Dungeon Walls Outline.png
  39. Now would be a good time to save, if you haven’t already. File->Save As…
    GIMP Save As Dialog.png
  40. Save the file as an .xcf (gimp native format). We will export it later for use in other ways, but for now, this will preserve the layers.
  41. Now, click Select->By color… and, with the Walls layer selected, click the wall line. All the wall lines should now be selected.
  42. Select the pattern you want to use for your walls. I like Slate.
  43. On your Toolbox, click the Fill Bucket and make sure the Pattern fill option is selected
  44. Click inside the selected area. The walls should now have that pattern instead of the color used to draw them.
  45. To make them look a little better, add a bevel (Filters->Decor->Add Bevel…
  46. To make the walls pop a little, click Filters->Light and Shadow->Drop Shadow… You’ll have a new layer called Drop Shadow. You’ll get a dialog box that looks like this:
    Drop Shadow Config.png
  47. I just use the default values and click ok. Your image should now look something like this:
    Dungeon Walls Texture.png
  48. If you want your fill area to be the same as wall, just make sure that the pattern has not changed. If it has, select the pattern you used for your walls. If you want something else for your fill, select that pattern now. I’m going to stick with Slate.
  49. Create a new layer called Solid.
  50. Select The Walls Layer
  51. Click the fuzzy select tool on the toolbox:
    Img15.png
  52. Click in an area that should be solid. If you have some areas that are “disconnected” from the main body, you can use Shift+click to include those areas in your selection.
  53. Select the Solid Layer
  54. Select your Bucket Fill from the toolbox and make sure the Pattern fill is selected
  55. Click inside all the solid areas to fill with the pattern.
  56. Your image should look something like this:
    Dungeon Filled With Texture.png
  57. Because I like my “outside” the dungeon to have a different floor than the dungeon, we can use the Rectangle Select Tool:
    Img17.png
  58. In my image, I’m going to select a square that encompasses the bottom row of squares only.
  59. Then I’ll select the Dried Mud pattern.
  60. Select the Fill Bucket tool and make sure that the Pattern fill option is selected
  61. Then click inside the selected area.
  62. Unhide your Floor Layer and you can see how things are coming together. My dungeon looks like this:
    Dungeon With Fill and Floor.png
  63. Save.
  64. Clean up, before we put the finishing touches on the map. Hide all the layers, except for Walls and Drop Shadow.
  65. Now, click on Layer->Merge Down. This will combine those two layers together., So, now you shouldn’t have a Drop Shadows layer, but just a Walls layer that has the Drop Shadows on it, too.
  66. Now to add doors to our rooms… Unhide the Background and the Grid Layers and leave Walls visible, too.
  67. Create a new layer called Doors. I like to keep the layers separate, in case I mess something up, I don’t mess up everything else I’ve done. Make sure the Doors layer is selected.
  68. Select a pattern you think will be good for doors.
  69. Select the Paintbrush tool and select a brush you want to use for the doors. I like Circle (07). It’s slightly smaller than the walls.
  70. Using the same technique you used for the walls, place the doors on the map where they belong. You should still be using the same foreground color that was used to paint the walls before we applied the pattern.
  71. Once your doors are on, Select->By Color and select one of the “doors.”
  72. We are now going to use the same steps we used for the walls (steps 41-47): Bucket fill with Pattern fill selected, Fill in the doors, Filter->Decor->Add Bevel…, Filter->Light and Shadow->Drop Shadow…
  73. Hide all the layers except for Drop Shadow and Doors
  74. Select the Drop Shadow layer (should be the top layer) and Layer->Merge Down. You should now only have one layer for Doors and no layer for Drop Shadow.
  75. Unhide Walls, Solid, Grid (if you wish), Floor and Background. Your map should look something like this:
    Dungeon Map Complete.png
  76. I like the Doors layer to be right below the Walls layer, so the doors don’t overlap above the walls.
  77. Save.
  78. You can now populate your map with whatever furniture, monster, etc. you desire. (See the Tips and Tricks page for some URLs where you can get some of these things). My recommendation is to do this population on a separate layer.
  79. File->Save a Copy… Under Select File Type select the type of file you will want to use for Roll20, I like PNG files. When prompted, select Merge Visible Layers and then click Export, and when prompted, click Save (I typically don’t change any of the defaults on the pop-up window).
  80. You are now ready to use your map

See Also